Paddle.com: Some customers may experience increased latency during checkout – 28th July 1434-16:19hrs UTC

Incident Report for 3Commas

Resolved

After monitoring, as of 16:12 UTC July 29, 2025, the issue causing checkout latency issues has been fully resolved. The checkout service is stable and working as expected.
Posted Jul 30, 2025 - 06:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 16:19 UTC

Identified

Dear Traders,

Our payment processing partner, Paddle.com, reported that some customers may experience increased latency during checkout on July 28th, from 14:34 UTC.

Currently, the team has rolled back some changes, which has stabilised the service.

Thank you for your patience!

More information can be found on Paddle's service status page here: https://status.io/pages/incident/58b845a59243e72262001ccf/688790caa9f3f105ec6e116b
Posted Jul 28, 2025 - 15:17 UTC
This incident affected: 3Commas Systems Status (Payment Processing Gateways).