Gemini: Update your API permissions before May 31st, 2025

Incident Report for 3Commas

Update

Dear Traders!

Gemini has recently updated the API key protection. To keep your bots running smoothly, all users are required to update their Gemini API settings by May 31.

Good news: 3Commas now supports IP whitelisting for Gemini!

You need to edit your existing Gemini API key, select “Trusted IPs Only” under allowlist, and copy the IP address listed in your 3Commas account to Gemini.

No changes are required in 3Commas – only on the Gemini website.
Need help with this? Please check out our updated guides:
Gemini API Settings Update: https://help.3commas.io/articles/11426954
More about security on 3Commas: https://help.3commas.io/articles/4456595

If you need further help, please contact our support team using the chat messenger when logged in to your 3Commas account.

Thank you for your cooperation!
Posted May 30, 2025 - 11:09 UTC

Identified

Dear Gemini and 3Commas traders,

Gemini have announced that on May 31st, they will disable the trading permissions of API keys that you have connected to 3rd party systems, including 3Commas.

In order for your bots and trades to not suffer disruption, it is important to:

Login to your Gemini exchange account via the Gemini web site

Edit your API key permissions and selected the “Unrestricted IP address” option

If you require further assistance, please visit our Help Article https://help.3commas.io/articles/11426954 for more detailed information for the required steps, or reach out to our support team using the chat messenger when logged-in to your 3Commas account.

Thank you for your cooperation!
Posted May 22, 2025 - 15:10 UTC
This incident affects: Exchanges API (Gemini API).