Users may experience issues with DCA bot deals closing for Coinbase Advanced.
Incident Report for 3Commas
Resolved
We are pleased to announce that we are marking this issue as resolved.
Our decision to revert to using the REST API on the 29th April has led to the provision of accurate order book price data.

For Coinbase Advanced traders who suspect that their trading activities were impacted by this issue between the 26th and 29th of April, we kindly request that you reach out to our support team. Please supply your Deal or Trade ID numbers, and we will be able to provide you with information regarding the price information received from Coinbase for the trading pairs, which will assist you in logging these with the Coinbase support team.

As of now, we have not received any updates from the Coinbase team regarding the cause of the problem with the websocket order book feed, however we hope to reintroduce support for it again in the future, as soon as they have resolved the issue.
Posted May 02, 2024 - 15:16 UTC
Monitoring
Dear traders,
We would like to provide you with an update regarding the current situation. Our team has been actively investigating the issue, and here is the latest information we have gathered:

1. Several months ago, Coinbase introduced a feature that allows for faster and more efficient receipt of orderbook updates for trading pairs through websockets.
In response to this development, our team at 3Commas updated our system at that time to leverage this feature, aiming to enhance the trading experience for users with bots or active trades on Coinbase accounts.

2. On 26th April at approximately 1045hrs UTC+0, reports surfaced from users indicating that some of their DCA bots were closing deals at a loss. This was identified as stemming from incorrect chart pricing received via the websocket orderbook feed.
A notification was promptly shared on the status.3commas.io page to alert traders to this issue.
Furthermore, our team reached out to Coinbase directly to report the problem, seeking their assistance in identifying and rectifying the issue.

3. As of 29th April at 0830hrs UTC+0, challenges persist in the accuracy of orderbook data received via the API from Coinbase.
In response, our team reverted to utilizing the older REST API method to update trading pair order books and pricing data. This adjustment is expected to provide more precise information and serve as a temporary workaround until a permanent resolution for the websocket data issue is implemented by Coinbase.
Posted Apr 29, 2024 - 09:43 UTC
Investigating
Dear Traders,
We’ve been made aware of technical issues with the Coinbase Advanced DCA bot deals and are monitoring the situation closely.

During this time, we would recommend not using market orders and any trailing feature at all until the problem is resolved.

We will notify you once systems are fully operational and appreciate your understanding!

Don’t forget you can review the latest status of 3Commas, including our supported exchanges, for planned and unplanned maintenance notifications at: status.3commas.io
Posted Apr 26, 2024 - 11:20 UTC
This incident affected: 3Commas Tools (DCA bot deals).