Paddle.com: Some subscription emails are currently incorrect – 17th Jul 2025 1133hrs UTC

Incident Report for 3Commas

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 12:57 UTC

Identified

Dear Traders,

3Commas' payment processing partner, Paddle.com, reported that starting from 11:33 UTC on July 17th, they have been experiencing an issue causing emails to display an incorrect renewal date and omit the subscription management URL. This affects buyers who receive a subscription receipt email when the subscription includes a free trial period or an initial invoice.

Their team is currently investigating the issue and working to resolve it as quickly as possible.

More information can be found on Paddle's service status page here: https://status.io/pages/incident/58b845a59243e72262001ccf/6878df7ed63d5344b0a67b6e
Posted Jul 17, 2025 - 11:51 UTC
This incident affects: 3Commas Systems Status (Payment Processing Gateways).