Gemini: Trading services upgrade – 17th November 0800-0900hrs UTC

Incident Report for 3Commas

Resolved

The maintenance has been completed.
Posted Nov 17, 2025 - 08:56 UTC

Identified

Dear Traders,

We were made aware that Gemini exchange has announced scheduled maintenance to upgrade and optimize the trading service at 08:00 – 09:00hrs UTC on 17th November, 2025.

The maintenance is now in progress.

More information is on the Gemini website, here: https://status.gemini.com/incidents/qtrbw127n4gk
Posted Nov 17, 2025 - 08:44 UTC
This incident affected: Exchanges API (Gemini API).