3Commas: Intermittent "Invalid API" messages displayed
Incident Report for 3Commas
Resolved
This incident has been resolved.
Posted Jun 04, 2023 - 12:15 UTC
Update
Dear traders,
Binance have confirmed that they have completed the work on their permanent fix for the "Invalid API" issue.

If you see this warning on your https://app.3commas.io/accounts page, or active Binance deals/trades, please click the refresh button by the exchange connection.

If you still are experiencing issues with this problem, please reach out to our support team, but we believe the issue should now be resolved for everyone affected.

We will closely monitor this situation for the next 24 hours.

Thank you for your patience.
Posted Jun 02, 2023 - 20:38 UTC
Update
Dear traders,
Some users are still experiencing issues with "Invalid API" messages for Binance exchange accounts.
We've been in communication with Binance and their engineers have identified the cause and are aiming to release a permanent fix within the next 24-36 hours.
Thank you for your patience, we will provide further updates as we receive them.
Posted Jun 02, 2023 - 12:29 UTC
Monitoring
Binance have reported that a fix has been applied; if you have a Binance exchange connection in 3Commas on the https://app.3commas.io/accounts page that is displaying an "Invalid API" message, please click the "refresh" button and it should clear.

An update for Bybit users that may see the warning "Not enough permissions for api keys" by active deals or trades, our logging indicates that some users may have outdated settings configured on Bybit exchange.
We'd recommend that users update their API key using Fast Connect to ensure all the correct settings are entered:
https://help.3commas.io/en/articles/7273792-bybit-how-to-connect-and-update-the-connection-with-the-fast-connect-feature
Posted Jun 01, 2023 - 19:04 UTC
Identified
Dear traders,
We've identified the problem and for Binance users the issue originates from the exchange, we have been in communication with Binance and they are implementing a fix.
For Bybit users, we have enabled a higher level of logging to identify the cause of the problem.

Thank you for your patience!
Posted Jun 01, 2023 - 15:21 UTC
Investigating
Dear traders,
We've had reports from Binance and Bybit users that they may be seeing erroneous messages by their linked exchange accounts, active DCA bot deals or SmartTrades stating “API key is no longer valid” or "Invalid API".
If the API key is updated (with or without using Fast Connect) then the message is displayed again within 24 hours.

Our team is investigating the reason this is occurring and for the majority of users the warning displayed is transitory and should clear by itself after a few minutes (or if you click the "refresh" button from the Portfolios page).

We apologize for any inconvenience caused and will provide updates as soon as they become available..
Posted May 31, 2023 - 17:41 UTC
This incident affected: Exchanges API (Binance.com API, Binance Futures API, Bybit API).