Intercom is still experiencing intermittent issues, with customers encountering slowdowns and errors throughout the application.
The team is working closely with AWS and continues to work on stabilizing the platform and reducing delays, but customers are expected to continue to experience periods of increased delays and increased error rates until services are fully restored.
Posted Oct 20, 2025 - 18:41 UTC
Monitoring
The service is currently in recovery, and the team is monitoring system stability closely
Posted Oct 20, 2025 - 09:33 UTC
Identified
Dear Traders,
Our support provider, Intercom, recently reported a major outage on October 20th at 07:00 UTC. All Intercom tools can be unavailable to the users, affecting the processing of emails, messages, notifications and Help Center.
It has been identified that the cloud provider delivering services to the intermediary is experiencing significant disruptions that are impacting their performance as well as much of the internet in their region (https://health.aws.amazon.com/health/status). Intercom is in contact with the provider to resolve the issue as quickly as possible.