Cloudflare: ORD (Chicago) and DTW (Detroit) datacenters maintenance – December 05th 0700-1300hrs UTC

Incident Report for 3Commas

Resolved

The maintenance has been completed.
Posted Dec 05, 2025 - 13:01 UTC

Investigating

Dear Traders,

We have been made aware that Cloudflare will be performing scheduled maintenance in their ORD (Chicago) and DTW (Detroit) data centers on December 5, 2025, between 07:00 and 13:00 UTC. During this window, some exchanges and services that rely on Cloudflare in these regions may experience increased latency, intermittent connectivity issues, or temporary unavailability. Our infrastructure is operating normally; however, connectivity to affected exchanges may be impacted.

We are monitoring the situation and will update this message once the Cloudflare maintenance is completed.

Maintenance statuses may be tracked here: https://www.cloudflarestatus.com/incidents/kcfkdmbz3pdc and https://www.cloudflarestatus.com/incidents/hlr9djcf3nyp
Posted Dec 05, 2025 - 09:41 UTC