Coinbase Advanced: Coinbase will expire legacy API Keys on 5th February 2025

Incident Report for 3Commas

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 13:02 UTC

Monitoring

Dear Coinbase Advanced Traders,

On 22nd January and 29th January 2025, Coinbase wrote to all users that have old "legacy" API keys created on their Coinbase Advanced Trade accounts to say these legacy API keys will be deleted starting from 5th February.

If you are unsure if you will be affected, please search the email mailbox that is registered to your Coinbase account, you can search for any messages received from the Coinbase notification email address: info@mail.coinbase.com
Additionally, the email subject line is: [Action Required] Important updates to your Coinbase API key

If you have a legacy API key connected to 3Commas, please create a new API key and update your connection in 3Commas, to ensure your trades and bots will continue to operate without interruption.

For a guide how to update your Coinbase API keys, please visit our Help Article: https://help.3commas.io/en/articles/3166090-update-connected-exchange-account#h_1fd9937315

If you require any assistance, please don't hesitate to contact our support team support@3commas.io who are waiting to assist you!
Posted Feb 04, 2025 - 16:12 UTC
This incident affected: Exchanges API (Coinbase Advanced API).