Paddle.com: Checkout Completion Issues – 16th May 2035hrs UTC

Incident Report for 3Commas

Resolved

This incident has been resolved.
Posted May 20, 2025 - 07:44 UTC

Monitoring

Earlier, the Paddle team reported an issue causing a drop in checkout completions. A fix has already been implemented to address the underlying issue, and the systems are operational and being monitored to ensure ongoing stability.
The issue lasted for about an hour, precisely between 20:35 and 21:45 UTC

You can see details on the Paddle Status Page:
https://status.io/pages/incident/58b845a59243e72262001ccf/6827a17a5966e14bc370be6f
Posted May 17, 2025 - 03:35 UTC
This incident affected: 3Commas Systems Status (Payment Processing Gateways).